Project

General

Profile

Tâche #10655

Scénario #11239: Proposer une version récente de nodejs sur 2.4.2 pour Envole

Réaliser un backport du paquet nodejs de trusty tahr

Added by Mathieu Terroba about 6 years ago. Updated almost 6 years ago.

Status:
Fermé
Priority:
Bas
Assigned To:
Start date:
02/17/2015
Due date:
% Done:

100%

Estimated time:
6.00 h
Spent time:
Remaining (hours):
0.0

Description

La version de nodejs présente dans les dépôts ubuntu de la precise ne permet pas de faire tourner etherpad et ethercalc (qui nécessitent node >= 0.8.x)


Related issues

Related to Distribution EOLE - Demande #17606: Montée de version de nodejs sur EOLE 2.5.2 Classée sans suite

History

#1 Updated by Daniel Dehennin almost 6 years ago

  • Project changed from nodejs to Distribution EOLE
  • Target version deleted (Envole 4.0 RC)
  • Estimated time set to 6.00 h
  • Parent task set to #11239

#2 Updated by Daniel Dehennin almost 6 years ago

  • Status changed from Nouveau to En cours
  • Remaining (hours) set to 6.0

#3 Updated by Daniel Dehennin almost 6 years ago

On ne peut pas utiliser le paquet trusty tel quel sur precise :

  • Dépends de gyp version >= 0.1~svn1654 alors que nous avons 0.1~svn1031-1
  • Dépends de libv8-3.14-dev alors que nous avons libv8-3.7.12.22.

Il va falloir voir avec les dépôts untrusted

#4 Updated by Daniel Dehennin almost 6 years ago

  • Remaining (hours) changed from 6.0 to 3.0

#5 Updated by Daniel Dehennin almost 6 years ago

Problème de compilation avec OpenSSL de la distribution.

#6 Updated by Daniel Dehennin almost 6 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 3.0 to 0.0

Importation du paquet fourni par nodejs dans notre dépôt.

Paquet disponible en eole-2.4-unstable.

#7 Updated by Scrum Master almost 6 years ago

  • Status changed from En cours to Résolu

#8 Updated by Joël Cuissinat almost 6 years ago

root@scribe:~# apt-cache policy nodejs 
nodejs:
  Installé : (aucun)
  Candidat : 0.10.38-1chl1~precise1
 Table de version :
     0.10.38-1chl1~precise1 0
        500 http://eole.ac-dijon.fr/eole/ eole-2.4-unstable/main amd64 Packages
     0.6.12~dfsg1-1ubuntu1 0
        500 http://eole.ac-dijon.fr/ubuntu/ precise/universe amd64 Packages

Le paquet s'installe et la commande npm semble fonctionner.

#9 Updated by Joël Cuissinat almost 6 years ago

  • Status changed from Résolu to Fermé

#10 Updated by Joël Cuissinat about 4 years ago

  • Related to Demande #17606: Montée de version de nodejs sur EOLE 2.5.2 added

Also available in: Atom PDF