Project

General

Profile

Envole 7.9

Added by Arnaud FORNEROT 6 months ago

Roadmap = https://dev-eole.ac-dijon.fr/versions/587

Balado

  • Montée de version

Grr

  • Montée de version

Piwigo

  • Montée de version

Sacoche

  • Montée de version

Moodle

  • Montée de version

Edispatcher

  • Adaptation pour fonctionner avec Ninegate

Eportail

  • Prise en compte d'un annuaire AD sur le changement du password d'un utilisateur via son profil
  • Possibilité d'ajouter des PJ dans les annonces
  • Création des widgets Nextcloud Files et Calendars

Ethercalc

  • Dépendance sur Nineboard et non plus Etherhome

Etherpad

  • Dépendance sur Nineboard et non plus Etherhome
  • Génération de l'APIKey d'etherpad en pretemplate et non plus en postservice

Etherhome

  • Suppression en dépendance d'etherhome de l'installation d'etherpad et d'ethercalc

Gepi

  • Correctif pour passage du paquet sur EOLE 2.8

Kanboard

  • Montée de version en 1.2.20
  • Installation du plugin WeKanboard
  • Check et Upgrade de la base de données de Kanboard se fait à présent en postservice et non plus au 1er lancement de la mire d'accueil de Kanboard

Limesurvey

  • Correction sur insertion d'images
  • Adaptation de l'eolisation pour que Limesurvey puisse fonctionner sur AmonEcole

Moodle

  • Correctif postservice sur installation vierge de Moodle lors de l’installation des plugins

Nextcloud

  • Exclusion du phpCAS des flux de communication avec Collabora Externe

Nineboard

  • Ajout de l'entrée manquante dans la console d'administration sur la gestion des Murs Collaboratifs
  • Websocket accessible via alias apache et non via port

Ninegate

  • Websocket accessible via alias apache et non via port
  • Correction performance sur lecteur des alertes lues / non lues

Piwik / Matomo

  • Montée de version en 4.5.0

Posh-Profil

  • Correction = suppression d'un warning php affiché lors de l’exécution des synchronisations Nextcloud
  • Correction = orthographe sur log synchronisation Limesurvey

Scrumblr

  • Plus de dépendance sur etherhome

Sondpiwik

  • Correction = la sonde statistique envoyée à Envole était bloquée car notre certificat n'était pas validé
  • DNMA = Prise en compte dans la sonde des applications edispatcher et econnect

Wordpress

  • Montée de version en

LDAP TLS

Prise en compte de l'activation du support LDAP TLS pour les applications suivantes
eportail - kanboard - posh-profil - roundcube

Eole DB

Modification cosmétique pour les variables expertes associées à la notion d'EoleDB.
L'ensemble des variables en question sont à présent stockées dans la famille EoleDB et non plus dans une famille spécifique à l'application.
Modification apportée sur les applications suivantes
balado - calendrier - cdt - edispatcher - envole-connecteur - eportail - etherpad - fluxbb - gepi - grr - janus - kanboard - limesurvey - mahara - moodle - nextcloud - nineschool - ninesurvey - opensondage - piwigo - piwik - posh-profil - roundcube - sacoche - wordpress - xdesktop

Paquets

  • eole-balado-1.1.3+3-3
  • eole-calendrier-4.0+3-4
  • eole-cdt-5.5.0.3+2-21
  • eole-dispatcher-1.0+3-17
  • eole-envole-connecteur-1.2+2-32
  • eole-envole-dependances-1.0+3-8
  • eole-envole-themes-4.0+3-6
  • eole-envole-tools-1.0+2-17
  • eole-eportail-3.0+2-179
  • eole-ethercalc-1.1.0+4-9
  • eole-etherhome-1.0.1+2-5
  • eole-etherpad-1.8.7+4-17
  • eole-fluxbb-1.5.10+2-11
  • eole-gepi-1.7.4+2-9
  • eole-grr-3.4.2d+2-5
  • eole-janus-1.0+4-8
  • eole-kanboard-1.2.20+4-3
  • eole-limesurvey-3.26.2+3-6
  • eole-mahara-1.8+2-7
  • eole-moodle-update-3.10.7+4-8
  • eole-nextcloud-19.0.1+4-15
  • eole-nineboard-1.0+4-39
  • eole-nineschool-1.0+4-25
  • eole-ninesurvey-1.0+4-17
  • eole-nodejspkg-1.1+4-6
  • eole-nodepm2-4.4.0+4-9
  • eole-opensondage-1.0+2-22
  • eole-piwigo-12.2.0+2-1
  • eole-piwik-4.5.0+4-2
  • eole-posh-profil-4.0+2-181
  • eole-roundcube-2.05+3-11
  • eole-sacoche-2022-01-12+2-3
  • eole-scrumblr-0.2.0+4-6
  • eole-sondepiwik-1.0+2-35
  • eole-wordpress-5.8.2+4-1
  • eole-xdesktop-1.3+2-16

Comments