Projet

Général

Profil

Annonces

Distribution EOLE: Mise à jour corrective EOLE toutes versions

Ajouté par Joël Cuissinat il y a 6 jours

Les paquets candidats annoncés le 06/04/2017 seront diffusés en version stable vendredi 21/04/2017.

Modifications diffusées pour les versions EOLE >= 2.4.0

  • saisie de partage de tous types dans l'EAD pour le support de sauvegarde
  • instanciation d'un serveur en haute disponibilité sans synchronisation avec un deuxième nœud

Modifications diffusées pour les versions EOLE >= 2.5.0

  • migration : certaines valeurs sont forcées pour être cohérentes avec les nouvelles versions de logiciels

Modifications diffusées pour les versions EOLE >= 2.5.1

  • saisie de login de tous types dans l'EAD pour le support de sauvegarde

Modifications diffusées pour les versions EOLE >= 2.5.2

  • possibilité de générer des certificats clients pour des tunnels SSL
  • le mode "safesearch" est forcé sur Bing, Qwant et Youtube
  • correction du blocage du diagnose RVP en cas de nombre important de tunnels
  • prise en compte immédiate des filtres Web modifiés dans l'EAD sans redémarrage de e2guardian
  • Geo-IDE - Distribution : mise en place des droits de %%geoide_homedir en postservice

Modifications diffusées pour les versions EOLE >= 2.6.0

  • nouvelle option permettant l'activation du proxy RADIUS
  • désactivation de la configuration Apache par défaut de Sympa
  • correction de la restauration des bases de données avec Bareos

Les modifications diffusées sont détaillées dans les pages suivantes

Distribution EOLE: Mise à jour candidate EOLE toutes versions

Ajouté par Fabrice Barconnière il y a 20 jours

Un certain nombre de paquets sont éligibles pour passer en version stable sous 2 semaines.

Modifications proposées pour les versions EOLE >= 2.4.0

  • saisie de partage de tous types dans l'EAD pour le support de sauvegarde
  • instanciation d'un serveur en haute disponibilité sans synchronisation avec un deuxième nœud

Modifications proposées pour les versions EOLE >= 2.5.0

  • migration : certaines valeurs sont forcées pour être cohérentes avec les nouvelles versions de logiciels

Modifications proposées pour les versions EOLE >= 2.5.1

  • saisie de login de tous types dans l'EAD pour le support de sauvegarde

Modifications proposées pour les versions EOLE >= 2.5.2

  • possibilité de générer des certificats clients pour des tunnels SSL
  • le mode "safesearch" est forcé sur Bing, Qwant et Youtube
  • correction du blocage du diagnose RVP en cas de nombre important de tunnels
  • prise en compte immédiate des filtres Web modifiés dans l'EAD sans redémarrage de e2guardian
  • Geo-IDE - Distribution : mise en place des droits de %%geoide_homedir en postservice

Modifications proposées pour les versions EOLE >= 2.6.0

  • nouvelle option permettant l'activation du proxy RADIUS
  • désactivation de la configuration Apache par défaut de Sympa

Les modifications proposées sont détaillées dans les pages suivantes

Distribution EOLE: La fin du support d’EOLE 2.4 approche

Ajouté par Gérald Schwartzmann il y a 22 jours

Les modules de la version EOLE 2.4 s’appuient sur la distribution
GNU/Linux Ubuntu 12.04 LTS nommée également Precise Pangolin.

Cette version LTS d’Ubuntu est disponible depuis le 26 avril 2012 et
après 5 ans de maintenance son support s’arrête en avril 2017.

Afin d’être cohérent avec les agendas des utilisateurs le Pôle de
Compétences Logiciels Libres prend en charge son support jusqu’à fin
juin 2017.

Pour plus d’informations, vous pouvez consulter l’article :
https://pcll.ac-dijon.fr/eole/fin-support-deole-2-4/

Distribution EOLE: Mise à jour EOLE 2.4 et 2.5 et nouvelle image ISO 2.5.2.2

Ajouté par Daniel Dehennin il y a 28 jours

Depuis la version Lucid Lynx, Ubuntu a mis en place la politique « LTS Enablement Stacks » appelé aussi HWE (Hardware Enablement).

Cela permet aux publications intermédiaires « point releases (12.04.1, 12.04.2, …) » de supporter du matériel plus récent en intégrant un rétroportage des noyaux des versions non LTS à l’image ISO d’installation et ce jusqu’à l’apparition de la « point release .5 », qui elle, fournie le noyau de la version LTS suivante.

Ces noyaux intermédiaires sont aussi ceux sélectionnés automatiquement lors d’une migration d’une version plus ancienne, chez EOLE la présence d'un noyau intermédiaire vient d’un Upgrade-Auto depuis la version 2.3.

Le problème de ces noyaux intermédiaires c'est qu'il ne sont jamais migrés vers une version supérieure pour éviter de modifier l'état de la machine lors d’une mise à jour, en effet un noyau plus récent pourrait mal supporter un type donné de matériel.

Or ces noyaux intermédiaires ne sont pas des noyaux LTS (malgré la présence du mot lts dans le nom du paquet), leur durée de support est bien inférieur à ceux dit LTS, il est donc possible d'avoir des serveurs avec un noyau qui n'est plus maintenu !

Depuis la version 16.04, Ubuntu a corrigé ce fonctionnement, les images ISO d’installation, y compris les versions intermédiaires, n’installe plus que la version LTS du noyau (celui publié à la version de la 16.04.0), c’est à l’administrateur d’installer des versions plus récentes si le besoin se fait sentir.

Nous avons généré une nouvelle image ISO 2.5.2.2 qui est livrée avec un noyau maintenu pour toute la durée de vie de la version 2.5.

Pour déterminer si le noyau de vos serveurs est maintenu par Ubuntu, nous fournissons deux outils de diagnostique :

Si votre noyau n’est plus maintenu, les outils vous indiquent quel paquet installer afin de migrer vers un noyau maintenu par Ubuntu :

Distribution EOLE: EOLE 2.6.1-RC1

Ajouté par Joël Cuissinat il y a 28 jours

La version 2.6.1-rc1 de la méta-distribution EOLE a été mise à disposition des utilisateurs à des fins de tests uniquement.

Elle est construite sur une base Ubuntu 16.04 LTS.

Modules mis à disposition en version EOLE 2.6.1-rc1 :

  • Eolebase : création d'un module EOLE personnalisé
  • Amon : partage en toute sécurité d'un accès Internet entre les sous-réseaux d'un réseau local
  • Horus : contrôleur de domaine et serveur de fichiers administratif
  • Scribe : contrôleur de domaine et serveur de fichiers pédagogique
  • Seth : Active Directory basé sur Samba4
  • Eclair : serveur de clients légers GNU/Linux
  • AmonEcole : association du module Amon et du module Scribe
  • eSBL : serveur de fichiers, d'impression et de sauvegarde
  • eCDL : contrôleur de domaine
  • Sphynx : concentrateur de Réseau Virtuel Privé
  • Seshat : réplication d’annuaire et système d'authentification centralisés
  • Thot : annuaire centralisé orienté ENT
  • Zéphir : déploiement et gestion d'un parc de serveurs EOLE
  • Hâpy : solution de virtualisation
  • Hâpy Node : extension de ressources pour un module Hâpy

La version candidate d'EOLE 2.6.1 a fait l'objet d'une campagne de qualification.
Au total 874 exécutions de tests ont eu lieu au cours des différentes itérations.

Depuis la version EOLE 2.6.0, seule l'architecture AMD64 est proposée.
Vous pouvez télécharger l'images ISO depuis notre serveur HTTP.

Une partie de la documentation a d’ores et déjà été mise à jour pour cette nouvelle version : http://eole.ac-dijon.fr/documentations/2.6/
Les principales évolutions apportées par EOLE 2.6.1 sont détaillées dans les journaux de mise à jour : https://dev-eole.ac-dijon.fr/projects/modules-eole/wiki/Journaux261

Distribution EOLE: Mise à jour corrective EOLE toutes versions

Ajouté par Joël Cuissinat il y a environ un mois

Les paquets candidats annoncés le 28/02/2017 seront diffusés en version stable mardi 14/03/2017.

Modification diffusée pour les versions EOLE >= 2.4.0

  • ajout d'une vérification d'accès au répertoire dans le module EAD de gestion ACL

Modifications diffusées pour les versions EOLE >= 2.5.0

  • Zéphir
    • amélioration du support des caractères accentués dans les mots de passe
    • détection automatique des paquets additionnels EOLE pour les variantes créés par le script "creation_variante"

Modifications diffusées pour les versions EOLE >= 2.5.1

  • ProFTPD
    • mise à niveau du script d'init proftpd signalé en erreur par diagnose (modification intervenue depuis le 28/02/2017)
  • ecoStations version 2.4.5
    • nouvelle ergonomie
    • gestion d'un calendrier de saisie des jours où il ne faut pas allumer les machines

Modification diffusée pour les versions EOLE >= 2.6.0

  • correction du support des modules configurés en mode DHCP

Les modifications diffusées sont détaillées dans les pages suivantes

Distribution EOLE: Mise à jour candidate EOLE toutes versions

Ajouté par Joël Cuissinat il y a environ 2 mois

Un certain nombre de paquets sont éligibles pour passer en version stable sous 2 semaines.

Modification proposée pour les versions EOLE >= 2.4.0

  • ajout d'une vérification d'accès au répertoire dans le module EAD de gestion ACL

Modifications proposées pour les versions EOLE >= 2.5.0

  • Zéphir
    • amélioration du support des caractères accentués dans les mots de passe
    • détection automatique des paquets additionnels EOLE pour les variantes créés par le script "creation_variante"

Modifications proposées pour les versions EOLE >= 2.5.1

  • ecoStations version 2.4.5
    • nouvelle ergonomie
    • gestion d'un calendrier de saisie des jours où il ne faut pas allumer les machines

Modification proposée pour les versions EOLE >= 2.6.0

  • correction du support des modules configurés en mode DHCP

Les modifications proposées sont détaillées dans les pages suivantes

Distribution EOLE: Mise à jour corrective EOLE toutes versions

Ajouté par Joël Cuissinat il y a 2 mois

Les paquets candidats annoncés le 31/01/2017 seront diffusés en version stable jeudi 16/02/2017.

Modification diffusée pour les versions EOLE >= 2.4.2

  • Scribe : modification pour que le test du port du client ne bloque plus controle-vnc

Modification diffusée pour les versions EOLE >= 2.5.0

  • Zéphir : mise à jour des dictionnaires et correction d'erreurs mineures dans l'application

Modification diffusée pour les versions EOLE >= 2.5.1

  • EOE : correction de l'URL de l'api de changement de mot de passe

Modifications diffusées pour les versions EOLE >= 2.5.2

  • Upgrade-Auto (2.5.2 vers 2.6.0) : corrections mineures et suppression de la mention bêta
  • suppression des erreurs liées au nettoyage des rapports Lightsquid
  • EOP : implémentation de la fonctionnalité : "Permettre aux enseignants de changer le mot de passe de tous les élèves"

Modifications diffusées pour les versions EOLE >= 2.6.0

  • mise à niveau de la configuration NTP et du test diagnose associé
  • Hâpy : suppression de l'option LOCALTIME pour les modèles de VM
  • Zéphir : chargement d'une chaîne de certificat au lieu d'un certificat unique, désactivation du protocole SSLv23 encore présent dans l'un des services

Les modifications diffusées sont détaillées dans les pages suivantes

Documentations: Publication d'une documentation 2.6 et mise à jour en 2.5

Ajouté par Gérald Schwartzmann il y a 3 mois

Distribution EOLE: Mise à jour candidate EOLE toutes versions

Ajouté par Joël Cuissinat il y a 3 mois

Un certain nombre de paquets sont éligibles pour passer en version stable sous 2 semaines.

Modification proposée pour les versions EOLE >= 2.4.2

  • Scribe : modification pour que le test du port du client ne bloque plus controle-vnc

Modification proposée pour les versions EOLE >= 2.5.1

  • EOE : correction de l'URL de l'api de changement de mot de passe

Modifications proposées pour les versions EOLE >= 2.5.2

  • Upgrade-Auto (2.5.2 vers 2.6.0) : corrections mineures et suppression de la mention bêta
  • suppression des erreurs liées au nettoyage des rapports Lightsquid
  • EOP : implémentation de la fonctionnalité : "Permettre aux enseignants de changer le mot de passe de tous les élèves"

Modifications proposées pour les versions EOLE >= 2.6.0

  • mise à niveau de la configuration NTP et du test diagnose associé
  • Hâpy : suppression de l'option LOCALTIME pour les modèles de VM
  • Zéphir : chargement d'une chaîne de certificat au lieu d'un certificat unique, désactivation du protocole SSLv23 encore présent dans l'un des services

Les modifications proposées sont détaillées dans les pages suivantes

(1-10/351)

Formats disponibles : Atom