Project

General

Profile

Tâche #22097

Updated by Gérald Schwartzmann about 2 years ago

Suite aux tests sur la demande #21595 le passage de 2.5.2 à 2.6.1 est bloqué par le paquet proftpd de la version 2.6.1.

<pre>
Paramétrage de proftpd-basic (1.3.6-1~eole26) ...
usermod: no changes
insserv: warning: script 'K01sympa' missing LSB tags and overrides
insserv: warning: script 'sympa' missing LSB tags and overrides
insserv: script eole-sympa-tic: service sympa already provided!
* Starting ftp server proftpd
2017-11-15 16:53:57,783 reseau proftpd[442]: processing configuration directory '/etc/proftpd/conf.d/'
...done.
</pre>

<pre>
root 30245 0.0 0.0 0 0 ? Z 16:53 0:00 [proftpd-basic.p] <defunct>
</pre>

pas d'erreur dans jenkins à propos de proftpd : http://jenkins.eole.lan/jenkins/job/2.6.1/view/Tous/job/test-upgradeauto-scribe-252-2.6.1-amd64/19/consoleFull
/var/lib/dpkg/info/proftpd-basic.postinst : ligne 193 : 30144 Erreur de segmentation proftpd -t > /dev/null 2>&1 |
|
Correction appliquer pour contourner le problème : https://dev-eole.ac-dijon.fr/projects/eole-proftpd/repository/proftpd-dfsg/revisions/f32c8de4ebe0f0700ac680cb38b046ae0d12c283/diff

Si j'essaye de relancer l'upgrade :
<pre>
SystemError: Exécution de apt-eole -o --container current --json --log-level info list-upgrade pour le conteneur reseau impossible
</pre>

Back