Project

General

Profile

Evolution #6897

rendre upgrade.py compatible avec la version 2.3 (Zéphir)

Added by Bruno Boiget over 7 years ago. Updated about 7 years ago.

Status:
Fermé
Priority:
Normal
Category:
-
Start date:
12/13/2013
Due date:
12/20/2013
% Done:

100%

Spent time:
Distribution:
EOLE 2.4

Description

upgrade.py initialise un logger importé de pyeole. L'api n'est pas compatible avec celle présente sur Eole 2.3.

Vérifier que les fonctions sont disponibles dans pyeole et utiliser l'ancienne méthode le cas échéant.

Associated revisions

Revision e80e6dc4 (diff)
Added by Bruno Boiget over 7 years ago

Modification de l'initialisation du logger d'upgrade.py pour compatibilité Zéphir 2.3

Fixes #6897

History

#1 Updated by Bruno Boiget over 7 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#2 Updated by Gilles Grandgérard about 7 years ago

  • Assigned To changed from Bruno Boiget to Gérald Schwartzmann

#3 Updated by Gérald Schwartzmann about 7 years ago

  • Status changed from Résolu to Fermé

J'ai testé depuis Zéphir 2.3.11 mis à jour avec les paquets de dev :
conf-zephir eole-genconfig zephir-backend zephir-common zephir-creole3 zephir-dictionnaires zephir-doc zephir-web

Édition du serveur 2.3 dans Zéphir.
Etat actuel du serveur xxx → configuration → migration → générer
Préparation de la migration
Scribe 2.4 standard → Générer la configuration → lance gen_config
check des variables → enregistrement → "La configuration a bien été enregistrée"
exportation du fichier de configuration
arrêt de gen_config
Retour à la page d'état du serveur
voyant migration en jaune et lien vers l'action modifier

Also available in: Atom PDF