Project

General

Profile

Tâche #29249

Scénario #29319: Recompilation des paquets Samba

(MTES) Fournir un paquet Samba 4.11 installable manuellement sur EOLE 2.7

Added by Emmanuel IHRY 3 months ago. Updated 12 days ago.

Status:
Ne sera pas résolu
Priority:
Normal
Assigned To:
-
Start date:
01/17/2020
Due date:
% Done:

0%

Remaining (hours):

History

#1 Updated by Emmanuel IHRY 3 months ago

  • Subject changed from Fournir un paquet Samba 4.11 installable manuellement sur EOLE 2.7 to (MTES) Fournir un paquet Samba 4.11 installable manuellement sur EOLE 2.7

#2 Updated by Emmanuel IHRY 3 months ago

  • Target version changed from Prestation Cadoles 48-50 to MTES - Prestation Cadoles 48-50

#3 Updated by Remi BAPTISTE 3 months ago

Fournir un paquet samba 4.11 qui intègre les patch de sécurité ainsi que les nouvelles fonctionnalités de la 4.11.1 + ceux fonctionnels déjà existants ainsi que ceux fournis par Linagora ( Limitation du transfert de zone, correction du bug de demote d'un RODC)
Version samba 4.11.1 est disponible sur debian sid: https://packages.debian.org/sid/samba

#4 Updated by Benjamin Bohard 3 months ago

  • Target version changed from MTES - Prestation Cadoles 48-50 to Prestation Cadoles 48-50

Le paquet 4.11.1 distribué par Debian est un paquet de transition vers python 3 (samba abandonne complètement python 2 comme de juste puisque le support officiel des versions 2 de python s’arrête totalement en 2020).
La base de code client utilisé actuellement sur les modules EOLE s’appuie encore sur python 2.
Il sera nécessaire de porter ce code ou de modifier les options de compilation ou de se restreindre à la version 4.10 s’y on en croit le changelog de samba :

Python2 support
---------------

Samba 4.11 will not have any runtime support for Python 2.

If you are building Samba using the '--disable-python' option
(i.e. you're excluding all the run-time Python support), then this
will continue to work on a system that supports either python2 or
python3.

To build Samba with python2 you *must* set the 'PYTHON' environment
variable for both the 'configure' and 'make' steps, i.e.
   'PYTHON=python2 ./configure'
   'PYTHON=python2 make'
This will override the python3 default.

Except for this specific build-time use of python2, Samba now requires
Python 3.4 as a minimum.

#5 Updated by Remi BAPTISTE 2 months ago

OK pour le passage de la version 2 à 3 pour python en samba 4.11.
On partirait plus finalement sur la demande de création d'un paquet samba 4.9.15 ( dernière version mineure) de la 4.9. Cela répondrait également à nos attentes et on resterait sur une version python 2. Cela est-il possible?

#6 Updated by Joël Cuissinat 2 months ago

  • Due date deleted (12/13/2019)
  • Target version deleted (Prestation Cadoles 48-50)
  • Start date deleted (11/25/2019)

#7 Updated by Remi BAPTISTE 2 months ago

  • Related to Tâche #29291: (MTES) Fournir un paquet Samba 4.9.15 installable manuellement sur EOLE 2.7 added

#8 Updated by Joël Cuissinat 2 months ago

  • Parent task set to #29319

#9 Updated by Joël Cuissinat 22 days ago

  • Related to deleted (Tâche #29291: (MTES) Fournir un paquet Samba 4.9.15 installable manuellement sur EOLE 2.7)

#10 Updated by Joël Cuissinat 12 days ago

  • Project changed from EOLE AD DC to Distribution EOLE
  • Status changed from Nouveau to Ne sera pas résolu
  • Start date set to 01/17/2020

Also available in: Atom PDF