Project

General

Profile

Tâche #13180

Scénario #13013: Exécuter les tests eSBL 2.5.1

compiler les geobidules en 2.5.1

Added by Thierry Bertrand over 5 years ago. Updated over 5 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
09/21/2015
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Remaining (hours):
0.0

History

#1 Updated by Thierry Bertrand over 5 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Thierry Bertrand over 5 years ago

  • % Done changed from 0 to 50
  • Remaining (hours) changed from 1.0 to 0.75

[rebuildd] Log for successful build of eole-geo-ide-base_2.5.1-1, from eole, on eole-2.5.1-proposed-updates/all

en attente de geobidule distrib ...

#3 Updated by Thierry Bertrand over 5 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 50 to 100
  • Remaining (hours) changed from 0.75 to 0.25

[geo-ide-distribution] Debian source package: Build successful: 2.5.1-1 for eole-2.5.1-proposed-updates

#4 Updated by Alain Guichard over 5 years ago

module esbl version 2.5.1 (esbl251 IDA-AG)

I) Maj-Auto -C -S test-eole.ac-dijon.fr

=> 0 nouveau, 6 mis à jour, 0 à enlever
Paquets à mettre à jour :
creole (2.5.1-5) (root)
creole-common (2.5.1-5) (root)
eole-common-pkg (2.5.1-5) (root)
eole-resolvconf (2.5.1-5) (root)
eole-server (2.5.1-5) (root)
python-creole (2.5.1-5) (root)

II) pas de paquet geo-ide
root@esbl251:~# dpkg -l |grep geo-ide
root@esbl251:~#

III) Erreur à l'installation paquet eole-geo-ide-base
root@esbl251:~# apt-eole install eole-geo-ide-base
Action install pour root
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
eole-geo-ide-base : Dépend: geo-ide-base-php mais il n'est pas installable
Dépend: php-yii mais il n'est pas installable
Dépend: mitab mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

IV) Installation paquet eole-geo-ide-distribution
root@esbl251:~# apt-eole install eole-geo-ide-distribution
Action install pour root
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les NOUVEAUX paquets suivants seront installés :
eole-geo-ide-distribution
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 5 094 o dans les archives.
Après cette opération, 56,3 ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://test-eole.ac-dijon.fr/eole/ eole-2.5.1-proposed-updates/main eole-geo-ide-distribution all 2.5.1-1 [5 094 B]
5 094 o réceptionnés en 0s (94,9 ko/s)
Sélection du paquet eole-geo-ide-distribution précédemment désélectionné.
(Lecture de la base de données... 75975 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../eole-geo-ide-distribution_2.5.1-1_all.deb ...
Décompactage de eole-geo-ide-distribution (2.5.1-1) ...
Paramétrage de eole-geo-ide-distribution (2.5.1-1) ...

VI) Paquet geo-ide installé
dpkg -l |grep geo-ide
ii eole-geo-ide-distribution 2.5.1-1 all Geo-IDE-distribution

VI) reconfigure OK

VII) reboot OK

VIII) diagnose OK

#5 Updated by Alain Guichard over 5 years ago

Installation paquet eole-geo-ide-base (2ème tentative)

I) Ajout comme source de paquet le dépot de dev 2.5.1
echo "deb http://debmiroir-02.ac.centre-serveur.i2/mirror/debdev/ eole-2.5.1/all/" >> /etc/apt/sources.list.d/debdev251.list
où se trouvent les dépendances et le paquet eole-geobase 2.4

II) # apt-eole install eole-geo-ide-base
Action install pour root
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets supplémentaires suivants seront installés :

gdal-bin geo-ide-base-php libarmadillo4 libarpack2 libblas3 libdap11
libdapclient3 libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1
libgfortran3 libgif4 libhdf4-0-alt libhdf5-7 libjemalloc1 libkml0 liblapack3
libnetcdfc7 libodbc1 libogdi3.2 libproj0 libquadmath0 libspatialite5
liburiparser1 libwebp5 libxerces-c3.1 make mitab odbcinst odbcinst1debian2
p7zip php-yii php5-pgsql php5-redis php5-xmlrpc postgresql postgresql-9.3
postgresql-client-9.3 postgresql-client-common postgresql-common proj-data
redis-server redis-tools

Paquets suggérés :

python-gdal libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 libmyodbc
odbc-postgresql tdsodbc unixodbc-bin ogdi-bin make-doc p7zip-full oidentd
ident-server locales-all postgresql-doc-9.3

Paquets recommandés :

proj-bin

Les NOUVEAUX paquets suivants seront installés :

eole-geo-ide-base gdal-bin geo-ide-base-php libarmadillo4 libarpack2
libblas3 libdap11 libdapclient3 libepsilon1 libfreexl1 libgdal1h
libgeos-3.4.2 libgeos-c1 libgfortran3 libgif4 libhdf4-0-alt libhdf5-7
libjemalloc1 libkml0 liblapack3 libnetcdfc7 libodbc1 libogdi3.2 libproj0
libquadmath0 libspatialite5 liburiparser1 libwebp5 libxerces-c3.1 make mitab
odbcinst odbcinst1debian2 p7zip php-yii php5-pgsql php5-redis php5-xmlrpc
postgresql postgresql-9.3 postgresql-client-9.3 postgresql-client-common
postgresql-common proj-data redis-server redis-tools

0 mis à jour, 46 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 27,0 Mo dans les archives.
Après cette opération, 108 Mo d'espace disque supplémentaires seront utilisés.
ATTENTION : les paquets suivants n'ont pas été authentifiés.

php-yii geo-ide-base-php mitab

E: Il y a des problèmes et -y a été employé sans --force-yes
apt-eole - l'appel à apt-get (-c /etc/apt/apt-eole.conf install eole-geo-ide-base) a retourné une erreur (code 100). Voir /var/log/apt/term.log

#6 Updated by Alain Guichard over 5 years ago

Info :
vincent.chavanon: alain.guichard: le soucis resemble a un pb de clé du dépot : as tu sur ta machine, ds /etc.apt/trusted.gpg.d/ un pner.gpg ?

Vérification :
ll /etc/apt/trusted.gpg.d/
total 12
drwxr-xr-x 2 root root 4096 sept. 23 15:32 ./
drwxr-xr-x 6 root root 4096 sept. 25 09:24 ../
.-rw-r--r-- 1 root root 1727 sept. 23 15:32 eole-archive-keyring.gpg
=> pas de fichier "pner.gpg"

#7 Updated by Alain Guichard over 5 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

1) Copie du fichier "pner.gpg" sous "/etc/apt/trusted.gpg.d/"
ll /etc/apt/trusted.gpg.d/
total 16
.drwxr-xr-x 2 root root 4096 sept. 25 12:14 ./
.drwxr-xr-x 6 root root 4096 sept. 25 09:24 ../
.-rw-r--r-- 1 root root 1727 sept. 23 15:32 eole-archive-keyring.gpg
.-rw-r--r-- 1 root root 1199 mars 31 15:54 pner.gpg

2) # Query-Auto

3) # apt-eole install eole-geo-ide-base
=> OK

4) Vérification
dpkg -l| grep geo-ide
ii eole-geo-ide-base 2.4.1-1-3 all Geo-IDE-base
ii eole-geo-ide-distribution 2.5.1-1 all Geo-IDE-distribution
ii geo-ide-base-php 2.1.2-4 all Application Géo-IDE Base (P0 / P2)
=> OK

Also available in: Atom PDF