Project

General

Profile

Anomalie #3003

Erreur à l'installation d'ajaxplorer si pas de paquet eole-fichier

Added by Emmanuel GARETTE over 10 years ago. Updated over 7 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
-
Target version:
Start date:
03/03/2012
Due date:
% Done:

100%

Distribution:
EOLE 2.4

Description

Il faudrait pouvoir installer eole-ajaxplorer sans eole-fichier (ce qui est le cas par défaut puisque pas de dépendance).

Mais :

erreur lors du chargement de /usr/share/eole/creole/dicos/61_ajaxplorer.xml : variable de condition "activer_proftpd" inconnue
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/pymodules/python2.6/creole/process.py", line 92, in load
    raise TemplateError, e
creole.error.TemplateError: variable de condition "activer_proftpd" inconnue

De plus, il faudrait pouvoir configurer l'adresse IP du serveur FTP.

Le patch de 61_ajaxplorer.xml permet de le faire.

Mais dans ce cas :

creole.error.TypeEoleError: ajaxplorer_ftp - erreur à l'exécution de calc_container (ligne 251): local variable 'variable' referenced before assignment

Comme le conteneur fichier n'existe pas, une erreur se produit. Le patch eosfunc permet de renvoyer "" si le conteneur n'existe pas pour la fonction calc_container.

61_ajaxplorer.patch View (1.55 KB) Emmanuel GARETTE, 03/03/2012 02:32 PM

eosfunc.patch View (915 Bytes) Emmanuel GARETTE, 03/03/2012 02:32 PM


Related issues

Related to eole-jappix - Anomalie #2211: Intégration du webchat jappix dans EOLE Fermé 10/13/2011
Related to ajaxplorer - Evolution #4919: Il ne manque presque rien pour qu'Ajaxplorer2 fonctionne sous Horus Ne sera pas résolu

History

#1 Updated by Joël Cuissinat over 10 years ago

Je relie cette demande à jappix car la problématique va être la même entre eole-jappix et eole-ejabberd :)

Concernant le "calc_conteneur", on peut peut-être jouer avec les "optionnal=True" mais c'est bien aussi que la fonction le gère...

Avec tout ça et la proposition que tu as faite par mail pour "préparer" les groupes de conteneurs à l'avance ça devrait le faire !!!

#2 Updated by Joël Cuissinat over 10 years ago

  • Target version set to Envole 3.3.1

#3 Updated by Arnaud FORNEROT about 10 years ago

  • Target version changed from Envole 3.3.1 to Envole 3.3.2

#4 Updated by Arnaud FORNEROT almost 10 years ago

  • Target version changed from Envole 3.3.2 to Envole 3.3.3

#5 Updated by Arnaud FORNEROT over 9 years ago

  • Target version changed from Envole 3.3.3 to Envole 3.3.4

#6 Updated by Arnaud FORNEROT over 9 years ago

  • Target version changed from Envole 3.3.4 to Envole 3.3.5

#7 Updated by Arnaud FORNEROT over 9 years ago

  • Target version deleted (Envole 3.3.5)

#8 Updated by Arnaud FORNEROT almost 8 years ago

  • Status changed from Nouveau to Résolu
  • Target version set to Envole 4.0 RC
  • % Done changed from 0 to 100
  • Distribution changed from EOLE 2.3 to EOLE 2.4

Ajaxplorer n'est plus maintenu maintenant c'est pydio
Le problème est résolu sur pydio
Si pas de domaine samba on ne monte pas de repository ftp sur le domaine en question
Par contre deux nouvelles variables expert

Activer un repository local
qui placera les fichiers dans /home/ww-data
pas de permissions

Activers un repository distant FTP
si l'ip du serveur FTP est associée au même eolesso alors il est possible d'ouvrir le partage distant

#9 Updated by Arnaud FORNEROT over 7 years ago

  • Status changed from Résolu to Fermé

Also available in: Atom PDF